Tried to Install Bare.Game on Kubuntu 14.04 64

Discussion related to the development of Bare Game http://www.baregame.org
PaulMichell
Posts: 2
Joined: Mon Feb 09, 2015 9:53 am

Tried to Install Bare.Game on Kubuntu 14.04 64

Postby PaulMichell » Mon Feb 09, 2015 10:04 am

Hello,

I have just tried to install Bare.Game on Kubuntu 14.04 64 and building barerun.lpk failed here:

Compiling package barerun 0.0: Exit code 256, Errors: 2, Warnings: 2, Hints: 9
bare.system.pas(2033,5) Warning: unreachable code
bare.system.pas(2370,39) Hint: Variable "Buffer" does not seem to be initialized
bare.system.pas(2451,41) Hint: Variable "Buffer" does not seem to be initialized
bare.types.pas(148,18) Note: Private type "TList$1.PItem" never used
bare.interop.openvg.pas(520,106) Hint: C arrays are passed by reference
bare.interop.openvg.pas(520,119) Hint: C arrays are passed by reference
bare.interop.openvg.pas(521,88) Hint: C arrays are passed by reference
bare.interop.openvg.pas(521,101) Hint: C arrays are passed by reference
bare.geometry.pas(599,20) Warning: Some fields coming after "" were not initialized
bare.geometry.pas(685,3) Note: Local variable "F" is assigned but never used
bare.system.pas(148,18) Note: Private type "TList$1<TDictionary$2$crc40C725E9.TKeyValue>.PItem" never used
bare.text.pas(62,34) Error: Identifier not found "TItem"
bare.text.pas(62,14) Error: There is no method in an ancestor class to be overridden: "IndexOf(const <erroneous type>):LongInt;"

My freepascal/lazarus version info is:

Lazarus 1.5 r47654M FPC 3.1.1 x86_64-linux-qt

I built this from SVN sources this morning, so it should be completely up to date.
Am I doing something wrong?

Thanks,

Paul

sysrpl
Posts: 108
Joined: Thu Feb 05, 2015 6:31 pm

Re: Tried to Install Bare.Game on Kubuntu 14.04 64

Postby sysrpl » Mon Feb 09, 2015 9:30 pm

Try downloading Bare Game from its new location on github. Instructions are located here:

http://github.com/sysrpl/Bare.Game#install

PaulMichell
Posts: 2
Joined: Mon Feb 09, 2015 9:53 am

Re: Tried to Install Bare.Game on Kubuntu 14.04 64

Postby PaulMichell » Thu Feb 12, 2015 9:28 am

From my system:

git clone git@github.com:sysrpl/Bare.Game.git

fails with a permissions error. If I download the zip and try to build from that I still
get the same error as before.

sysrpl
Posts: 108
Joined: Thu Feb 05, 2015 6:31 pm

Re: Tried to Install Bare.Game on Kubuntu 14.04 64

Postby sysrpl » Thu Feb 12, 2015 3:12 pm

My bad, I posted the SSH method. Use the HTTPS method instead use:

git clone https://github.com/sysrpl/Bare.Game.git

Regarding your errors, Bare Game requires a newer version of FPC, fixes 3_0 branch or above. Check your FPC version if you know how.

You say you got the latest from SVN, which branch did you use? fixes_3_0 or trunk should work. If you got one of those two let me know which one and I'll investigate.


Return to “Bare Game”

Who is online

Users browsing this forum: No registered users and 1 guest